Jelenlegi hely

frissítés

Az OpenVPN 2.4.0 frissítés adminisztratív teendőket igényel

Az OpenVPN 2.4.0 olyan változásokkal érkezik, melyek inkompatibilisek a korábbi konfigurációs beállításokkal. Erre fordíts különös figyelmet, ha a távoli eléréshez VPN-t használsz. Rendszergazdai beavatkozás szükséges:

hírek címkéi: 

A ttf-dejavu 2.37 kényszerített frissített igényel

A ttf-dejavu 2.37-tel megváltozik a csomag fontconfig konfigurációja. A csomag korábbi verzióiban a post_install/post_upgrade szkript hozott létre szimbolikus linkeket, ezzel szemben az új verzióban a csomag tartalmazza a szükséges fájlokat.
További információk a változásról:
https://bugs.archlinux.org/task/32312

hírek címkéi: 

C++ ABI változás

A GCC 5.x verziótól a libstdc++ könyvtár új ABI-val (application binary interface-szel) érkezik, hogy megfeleljen a 2011-es C++ szabványnak.

Noha kompatibilitási okokból a régi C++ ABI is elérhető (a részleteket lásd itt), azt javasoljuk, hogy a repón kívüli, saját csomagokat fordítsátok újra az új ABI-hoz. Ez különösen akkor fontos, ha a csomag új ABI-val készült könyvtárhoz van linkelve. A következő shell-script kilistázza az újrafordítandó csomagokat:

hírek címkéi: 

Adatvesztés szoftveres RAID 0-val, discard opció használata esetén

A legújabb Linux kernelekben (4.0.2+, LTS 3.14.41+) - melyek a [core] repóba is bekerültek -, volt egy hiba, amely adatvesztést okozhatott azokon a fájlrendszereken, amelyek discard opcóval lettek mountolva, és szoftveres RAID 0 tömbön voltak. Még ha a discard opció nem is volt explicit módon megadva, az fstrim parancs is előidézhette ezt a hibát. (Ha nem használsz szoftveres RAID-t vagy discard opciót, akkor ez a hiba téged nem érint.)

hírek címkéi: 

A Puppet 4 bekerült a [community] repóba

Kijött a Puppet 4, amely nem kompatibilis a 3-as verzióval. Ezért a felhasználóknak előbb a szervert kell frissíteniük Puppet 4-re, mielőtt frissítik a klienseket. Tartsuk észben azonban, hogy ha csak egy Puppet 4 szerver elérhető, akkor a Puppet 3 kliensek nem fognak működni. Ezenfelül számos dolog (pl. konfig, manifest és module fájl) helye megváltozott. Ajánlott tehát követni az alábbi instrukciókat a szerver és a kliensek frissítésénél:

hírek címkéi: 

Változások az Intel microcode frissítésben

Az Intel CPU-k microcode-ja a továbbiakban nem töltődik be automatikusan, mivel a boot folyamat nagyon korai szakaszában kell ennek megtörténnie. Emiatt a bootloader finomhangolása szükséges. Ha Intel CPU-d van, kérlek kövesd a wiki-ben leírt lépéseket.

Thomas Bächler, 2014-10-22

hírek címkéi: 

A MariaDB 10.0 bekerült az [extra] repóba

Az új MariaDB kiadás bekerült az [extra] repóba. A verziószámozásban változás történt, mely a MySQL 5.6-tól való megkülönböztetést is szolgálja. Mostantól nem egyszerű váltogatni a hivatalos repókban található különböző MySQL implementációk között.

A MariaDB 10.0 fontos változásai miatt ajánlott (de nem szükséges) a táblákat fájlba dumpolni frissítés előtt, majd visszatölteni őket a fájlból. A frissítés után ne felejtsd el újraindítani a mysqld.service szolgáltatást, illetve a mysql_upgrade-et futtatni az adatbázisok ellenőrzéséhez.

hírek címkéi: 

A screen-4.2.0 nem tud rákapcsolódni a régebbi példányokra

A screen felhasználók nem fognak tudni rákapcsolódni 4.2.0-ás screennel a régebbi verziójú elindított példányokra. Ennek az az oka, hogy jelentős upstream változások történtek a programkódban, és named pipe helyett socketekkel történik a kommunikáció. Kérjük, frissítés előtt győződj meg róla, hogy a futó screen sessionökre nincs szükséged.

Gaetan Bisson, 2014-04-20

hírek címkéi: 

Linux 3.13 FIGYELMEZTETÉS: A PS/2 billentyűzet támogatás modulba került

Olyan kérés érkezett hozzánk, hogy az i8042 billentyűzet és egér vezérlő driver kerüljön át modulba. Néhány ilyen hardverrel nem rendelkező felhasználó ugyanis furcsa hibaüzeneteket kapott, és lelassult a boot folyamatuk. Tom megoldotta a problémát kerneloldalon (köszönjük), munkájának eredménye bekerült a 3.13-as kernelbe.

hírek címkéi: 

Az /etc/sysctl.conf megszűnik

A 207-es verziótól kezdve a systemd többé nem olvas beállításokat az /etc/sysctl.conf fájlból, csak az /etc/sysctl.d/*-ból. Mivel időközben a procps-ng csomagunk által szállított /etc/sysctl.conf fájl beállításai alapértelmezetté váltak a kernelben, úgy döntöttünk, hogy elavultnak minősítjük ezt a fájlt.

Amikor procps-ng-3.3.8-3-ra frissítesz, kapsz egy pacman-üzenetet a teendőkről, vagyis az egyéni /etc/sysctl.conf-beállítások /etc/sysctl.d-be helyezéséről. Ennek legegyszerűbb módja a következő:

hírek címkéi: 

Oldalak

Feliratkozás RSS - frissítés csatornájára