Jelenlegi hely

frissítés

TeXLive frissítési probléma

Néhány szimbolikus linket áthelyeztünk a texlive-bin csomagból a texlive-htmlxml, -langgreek, -langextra, -pictures, -pstricks és -science csomagokba, ahová valók (ld. FS#16037). Az egyik sajnos lemaradt egy PKGBUILD-beli elírás következtében, így fájlütközés jött létre a texlive-bin és texlive-langgreek csomagok között. A megoldás a /usr/bin/mkgrkindex fájl felülírásának engedélyezése (a --force kapcsolóval).

François Charette, 2009-09-11

hírek címkéi: 

Udev minimális kernel verzió

Az udev 145-1 kiadás legalább 2.6.24.5-os verziójú kernelt igényel (a signalfd függvény miatt). Erősen ajánlott, hogy a legújabb kernelt használd, de ha ez nem lehetséges, vedd fel az udev csomagot az IgnorePkg listába, amíg nem áll rendelkezésre friss kernel.

Aaron Griffin, 2009-08-05

hírek címkéi: 

KDE 4.3: csomagolva és szétdarabolva

Az új nagy KDE kiadás nemcsak izgalmas fejlesztéseket tartalmaz, hanem újdonság az is, hogy több csomagban érkezik, így a felhasználók csak a szükségeseket telepíthetik fel.

Az összes fontos frissítés röviden:
- Szétdarabolt csomagok; további információk itt: http://wiki.archlinux.org/index.php/KDE_Packages, http://wiki.archlinux.org/index.php/DeveloperWiki:Splitting_KDE
- A Qt a gstreamer backendet használja a Phononhoz alapértelmezésként. Opcionálisan telepíthetők további backendek (mint például a phonon-xine).
- Metacsomagok biztosítják a gördülékeny frissítést, és a régi monolitikus csomagokat emulálják azok számára, akik ezt preferálják.

Fontos tippek a frissítőknek:
- Ellenőrizd, hogy a tükörszerver naprakész-e!

hírek címkéi: 

/dev struktúra változás

A /dev struktúrát kitakarítottuk, hogy az eszköznevek megegyezzenek a Linux kernel dokumentációban használtakkal. Maradt néhány elavult bejegyzés a devfs-es időkből, ezeket most eltávolítottuk. Fontos, hogy frissítéskor az initscripts (2009.07-3), a filesystem (2009.07-1), az udev (141-5) és a syslog-ng (3.0.3-2) csomagok egyszerre frissüljenek.

A legszembetűnőbb változás a felhasználók számára a vc/*->tty* váltás. Az initscripts-2007.08 frissítése az /etc/inittab módosítását igényli, hogy a tty* eszközre hivatkozzon vc/* helyett. Tekintve, hogy súlyos rendszerösszeomlás következne be, ha ez a fájl nem módosul megfelelően, ezt a változtatást a pacman automatikusan elvégzi. Az eredeti /etc/inittab fájlról /etc/inittab.pacsave néven biztonsági másolatot is készít. Egész pontosan:

hírek címkéi: 

A portmapet lecseréli az rpcbind & fontos nfs-utils frissítés

Üdv Arch közösség!
A portmapet lecseréli az rpcbind a [core] repóban.
Az rpcbind sokkal többet tud, például van benne IPv6 és NFS4 támogatás.
Kérlek módosítsd az /etc/rc.conf fájlt értelem szerint.

Fontos nfs-utils frissítés:
-NFS4 támogatás implementálva
Ez egy meglehetősen fontos frissítés, módosítanod kell a konfigurációs fájlokat is.

/etc/rc.conf démon változások:
1. portmap -> rpcbind
2. nfslock -> nfs-common
3. nfsd -> nfs-server

További NFS (kliens és szerver) konfigurációs lehetőségek az alábbi fájlokban:
/etc/conf.d/nfs-common
/etc/conf.d/nfs-server

hírek címkéi: 

A 2.6.30-as kernel széria bekerült a [core] repóba

Üdv Arch közösség!
A 2.6.30-as kernel széria bekerült a [core] repóba.

Upstream változások:
http://kernelnewbies.org/LinuxChanges

ArchLinux-specifikus változások:
-acpi-dsdt-initramfs.patch eltávolítva (Nincs működő patch ehhez a szériához. Ha egyéni DSDT-re van szükséged, kérlek forgasd bele a saját kerneledbe.)
-snd-pcspkr modul eltávolítva (FS#14958)
-DCCP támogatás (FS#15071)
-SCHED_DEBUG=y
-lzma kernel tömörítés

hírek címkéi: 

Az új module-init-tools csomaggal megváltozik a modprobe konfigurációs fájl helye

Az új module-init-tools 3.8 csomag már nem olvassa az /etc/modprobe.conf fájlt, ehelyett az /etc/modprobe.d/modprobe.conf használatos. Továbbá a jövőben figyelmen kívül lesznek hagyva azon /etc/modprobe.d-beli fájlok, amelyek nem .conf kiterjesztésűek.

A frissítés után kérlek ellenőrizd a szóban forgó konfigurációs fájlokat.

Thomas Baechler, 2009-06-19

hírek címkéi: 

vi, vim és gvim frissítés

Végre elérhetők az új vi* csomagok. A migrációval azonban lesz egy kis nehézség. Az optimális eredmény eléréséhez azt javasoljuk, hogy add ki a sudo rm /usr/bin/{view/rview} parancsot a sudo pacman -Syu futtatása előtt.

hírek címkéi: 

A Dovecot 1.1.14-re való frissítés felhasználói beavatkozást igényel

A pacman fájlütközés-vizsgálatának hiányossága miatt (nevezetesen, hogy tévesen ütközést észlel, amikor egy könyvtárat azonos nevű fájllal akar lecserélni egy csomag) a dovecot 1.1.14-1 csomagra való frissítés egy minimális felhasználói beavatkozást igényel. A frissítéshez most a "pacman -Sf dovecot" parancs használata ajánlott (és biztonságos) a két fájlütközés felülbírálására. Kérlek nézz rá a megváltozott szerkezetű /etc/dovecot/dovecot-example.conf fájlra is.

Andreas Radke, 2009-04-18

hírek címkéi: 

Oldalak

Feliratkozás RSS - frissítés csatornájára